Logs multiples Application Insight

  • R3dKap

    Membre
    7 janvier 2022 à 15h50

    Pas de mon côté désolé… Mais un p’tit Distinct() dans l’app Power Apps pour régler le pb ? 😁

    CommentID=Aap89sqn0fpZpwN, PostID=yK651wQmqWmaCbb

  • David Vachala

    Membre
    7 janvier 2022 à 17h24

    Pas de mon coté non plus.

    20 traces à la même heure à la seconde prêt …
    – Bugs ? si oui ==> Le support MS répondra
    – 20? combien de champs / colonnes sont mise à jour avec ton patch ?

    Laisse nous (autant que possible #confidentialité client), une capture d’écran de ton patch

    CommentID=HVwGhA7xNu4oh5C, PostID=yK651wQmqWmaCbb

  • Didier Gbenou

    Membre
    7 janvier 2022 à 18h12

    @Damien Moi non plus je n’ai jamais vu cela auparavant. Peux-tu partager une capture d’écran de l’endroit ou t’utilises la fonction trace()? Cette fonction est-elle a l’intérieur d’une loupe?

    Aussi, peux tu comparer les customDimensions pour voir si elles sont identiques? C’est un json que tu peux copier.

    CommentID=gYyLl5YH4IAqSid, PostID=yK651wQmqWmaCbb

  • Damien

    Membre
    10 janvier 2022 à 10h17

    Merci de vos réponses, voici quelques précisions.
    Nous faisons appel à la fonction Trace() de cette manière:

    Nous utilisons la fonction de Trace avant un appel à un connecteur personnalisé (qui réalise l’opération de Patch). Il s’agit donc bien d’un appel unique qui doit générer une seule trace.

    @Didier les customDimensions sont identiques.

    @R3dKap je ne suis pas sûr de pouvoir utiliser Distinct pour l’appel de cette fonction.

    @David nous sommes en relation avec MS.

    Il doit bel et bien s’agir d’un bug MS.

    CommentID=s2E2LTRtFd7QS7s, PostID=yK651wQmqWmaCbb

  • R3dKap

    Membre
    10 janvier 2022 à 11h46

    Non effectivement, le Distinct() n’a aucun sens dans ton cas de figure… Est-ce que tu peux préciser à quel endroit ta fonction Trace() est appelée précisément ? Parce-que je sais pas exemple que certains événements du type OnChange d’une combobox sont très mal gérés aujourd’hui dans Power Apps et génèrent de multiples déclenchement alors que le changement de valeur est unique. D’ailleurs, même en utilisant l’outil Monitor de Power Apps tu constateras de nombreux doublons de traces. A mon avis c’est inhérent au code interne de Power Apps lors de certaines opérations… Suis pas sûr qu’on va pouvoir y faire grand chose.

    Alors par contre, je pense à un truc : je peux toucher mot directement à l’équipe Power Apps chez MS (grâce à ma position de MVP 😉). Je vais voir ce que ça donne et je te tiens au jus…

    Mais précise-moi quand même juste avant, où tu as placé tes appels de Trace()…

    CommentID=tnH6bCzjm34jXDW, PostID=yK651wQmqWmaCbb

  • Damien

    Membre
    10 janvier 2022 à 16h12

    J’ai placé mes appels de Trace() dans un event OnSelect() d’un Bouton. Pour info ce problème n’arrive pas à tous les utilisateurs et n’apparait pas à tout les moments de la journée. Par exemple, traces multiples pour l’utilisateur 1 et pas pour l’utilisateur 2. Pas de traces multiples entre 13h et 16h. J’ai des difficultés à reproduire le bug.

    CommentID=j1yLFx0RtYYtAGd, PostID=yK651wQmqWmaCbb

  • David Vachala

    Membre
    10 janvier 2022 à 16h28

    @Damien , il te faut pouvoir reproduire l’anomalie et décortiqué ==> Tester chaque partie de ton code / application. A ce stade, il nous faudrait encore plus d’élément je pense pour t’aider (le support MS aussi … )

    Il y a toujours une logique mais là :
    – soit nous n’avons pas tous les éléments (peut être toi non plus pour l’instant dans tes investigations )
    – soit il y a un bug

    Dans tous les cas, il te faut pouvoir le reproduire, démontrer que ça fonctionne normalement dans un cas et pas dans l’autre … le tout documenté dans un document, si tu veux que le support MS t’aide rapidement.

    CommentID=WkXZNUkxHGluwxM, PostID=yK651wQmqWmaCbb

  • Damien

    Membre
    10 janvier 2022 à 16h40

    @David, oui j’en ai conscience! Je ne pensais pas que ce problème prendrait une telle ampleur c’est juste ça 😉

    J’essaye de reproduire le bug sur un environnement de test, mais il n’a lieu que sur un environnement de Production étant donné que c’est sur un environnement Client je ne peux pas faire ce que je veux et quand je le veux…

    Je vous remercie de votre implication, et vous tiens au courant de mon côté sur toute découverte de ma part.

    CommentID=xdXav7zmDN6LmBc, PostID=yK651wQmqWmaCbb

  • David Vachala

    Membre
    10 janvier 2022 à 16h55

    ok !

    Si c’est un environnement de production client, le support MS peut cloner ton environnement de PROD en en environnement “Support” c’est ainsi qu’ils font les tests chez les clients en restant dans la configuration client

    Si tu as la possibilité, créer un environnement Bac à sable et copie la PROD sur cet environnement ainsi tu reste dans “l’environnement “du client.

    Enfin et surtout si tu trouves la solution ou si MS t’apporte une solution : partage le à la communauté ! Toi aussi peux y contribuer 😉

    Merci !

    CommentID=bIkHIyQVKSTTN7b, PostID=yK651wQmqWmaCbb

Connectez-vous pour répondre.