Concaténation ne fonctionne plus

Étiquetté : ,

  • Concaténation ne fonctionne plus

    Posté par Geoffroy sur 17 novembre 2023 à 16h09

    Bonjour à tous,

    J’ai de nouveau un flux qui ne fonctionne plus comme avant. Cette fois-ci, il s’agit d’un flux qui va chercher les enregistrements de moins d’une semaine d’une liste SharePoint et qui concatène certains champs pour créer le corps d’un mail Outlook.

    Rien de bien sorcier mais la semaine dernière, ça marchait encore et aujourd’hui, je n’ai qu’un ou deux enregistrements au lieu des 7 espérés (et pas toujours les mêmes selon les tests).

    PostID=zcKs4Ah9fNvoeMm

    Geoffroy a répondu Il y a 4 mois, 3 semaines 1 Membre · 2 Réponses
  • 2 Réponses
  • DavidZed

    Membre
    18 novembre 2023 à 0h00

    Hello Geoffroy WAGNER ,

    Dans le JSON de sortie de ton obtenir les éléments, tu as bien 7 items ? Si ce n’est pas le cas, c’est les données ou le filtre Odata qu’il faut vérifier.

    Si tu as tes 7 items en sortie de requête, que tu as ensuite les 7 passages dans la boucle appliquer à chacun, c’est très certainement que ta boucle a l’exécution en parallèle activée, ce qui peut faire que tes actions de définitions de variables s’exécutent dans le désordre

    CommentID=8ut6G6wVgvRbAns, PostID=zcKs4Ah9fNvoeMm

  • Geoffroy

    Membre
    18 novembre 2023 à 9h28

    Merci beaucoup DavidZed

    C’est exactement ça. J’avais cru malin de mettre l’exécution en parallèle sur toutes mes boucles Appliquer à chacun en croyant que j’allais gagner du temps. Mais je n’avais pas pensé à cette conséquence.

    D’ailleurs, ça répond aussi à mon post sur le fichier excel qui sortait dans le désordre.

    Ca me rassure de savoir que ce n’est pas une évolution cachée de Power Automate qui en était responsable. 👍

    CommentID=GNaA4rncVbym9Um, PostID=zcKs4Ah9fNvoeMm

Connectez-vous pour répondre.