Problème de lenteur en fonction du déclencheur

Étiquetté : 

  • Problème de lenteur en fonction du déclencheur

    Posté par J L sur 26 mai 2023 à 8h35

    Bonjour à tous.
    J’espère que vous pourrez m’aider : j’ai créé un flux avec au départ un déclenchement instantané par bouton. Lors des tests, mon flux s’exécute en 1 minute max. Tout va bien.
    J’ai ensuite changé le trigger et mis un planificateur. Toutes les 20 minutes il devra se déclencher.
    nouveau test : plus de 20 minutes (où j’ai été obligé d’arrêter… je ne l’ai pas laissé continuer).
    En observant le flux, il bloque à ma boucle “apply to each”. J’ai activé le parallélisme, mais aucun changement.

    Le flux qui a été annulé durait plus de 27 minutes et restait bloqué dans la boucle

    Est ce que vous auriez une idée ?
    Merci pour votre aide

    PostID=Pjwsbkx84iyBDe1

    J L a répondu Il y a 4 mois, 2 semaines 1 Membre · 2 Réponses
  • 2 Réponses
  • DavidZed

    Membre
    26 mai 2023 à 10h14

    Hello J L ,

    Cela peut provenir de plusieurs choses, est-ce que tu as pu reproduire cela de manière systématique ? :

    • Avec un déclencheur manuel le flux se termine toujours en moins de 60 sec

    • Avec un déclencheur planifié le flux ne se termine jamais en moins de X minutes

    Tu peux ensuite vérifier quelques points :

    • Qu’il n’y avait pas de paramètre d’entre à ton trigger manuel

    • Qu’il n’y a pas eu de modifs des données entre les tests des différents triggers

    • Si le comportement est le même quand tu lance une exécution manuellement depuis la page des détails du flux (version avec le déclencheur plannifié)

    Il peut y avoir des facteurs externes :

    • il y a pas mal de perturbations à l’utilisation de Power Automate ces dernières semaines

    • Il n’est pas impossible que les flux instantanés soient priorisés en terme de ressources allouées par rapport aux flux planifiés ( c’est une spéculation )

    CommentID=c4oC6hfFKisReyf, PostID=Pjwsbkx84iyBDe1

  • J L

    Membre
    26 mai 2023 à 11h59

    Merci DavidZed pour tes réponses. Je vais essaye de t’en apporter également :

    est-ce que tu as pu reproduire cela de manière systématique ? :

    • Avec un déclencheur manuel le flux se termine toujours en moins de 60 sec

    • Avec un déclencheur planifié le flux ne se termine jamais en moins de X minutes

    -> Oui systématiquement :
    En flux manuel : entre 58s et 1m03s
    En flux planifié : entre 26min et 33min

    paramètre d’entre à ton trigger manuel : non aucun :/

    • Qu’il n’y a pas eu de modifs des données entre les tests des différents triggers : non plus, juste la modif du trigger

    • Si le comportement est le même quand tu lance une exécution manuellement depuis la page des détails du flux (version avec le déclencheur plannifié) : je vais le tester


    • DavidZed

      Expert

      Open options

      2 hours ago · Consultant Pwp Devoteam

      Hello J L ,

      Cela peut provenir de plusieurs choses, est-ce que tu as pu reproduire cela de manière systématique ? :

      • Avec un déclencheur manuel le flux se termine toujours en moins de 60 sec

      • Avec un déclencheur planifié le flux ne se termine jamais en moins de X minutes

      Tu peux ensuite vérifier quelques points :

      • Qu’il n’y avait pas de paramètre d’entre à ton trigger manuel

      • Qu’il n’y a pas eu de modifs des données entre les tests des différents triggers

      • Si le comportement est le même quand tu lance une exécution manuellement depuis la page des détails du flux (version avec le déclencheur plannifié)

      Il peut y avoir des facteurs externes :

      • il y a pas mal de perturbations à l’utilisation de Power Automate ces dernières semaines

      • Il n’est pas impossible que les flux instantanés soient priorisés en terme de ressources allouées par rapport aux flux planifiés ( c’est une spéculation )

        J’ai vu ça sur certains de mes flux dernièrement, mais pas à ce point….

    Merci beaucoup en tout cas. Je retente

    CommentID=3KQhCmisSFKUSop, PostID=Pjwsbkx84iyBDe1

Connectez-vous pour répondre.