Problème SAMEDATELASTYEAR avec groupby

  • Problème SAMEDATELASTYEAR avec groupby

    Posté par Eric sur 1 février 2024 à 14h57

    Bonjour,

    Je suis débutant avec PowerBI.

    J’ai une table ayant des demandes de services avec date et priorité.
    J’ai créé un Visuel TABLE avec les champs Priorité, Description et nombre de demande.

    Le visuel affiche ceci:

    Priorité Description Nombre de demande
    1 Critique 7
    2 Très urgent 57
    3 Urgent 29
    4 Important 3

    La période est sélectionnée par un visuel “Segment”.

    Je désire afficher dans mon visuel TABLE, une autre colonne contenant le nombre de demande à une pareil date l’année précédente.
    Je pensais me servir de SAMEPERIODLASTYEAR mais je n’ai réussis à le faire que pour une priorité à la fois.

    Dois-je le faire sous forme de champ calculé que je dois ajouter à la table source des demandes?
    Voici la formule que j’avais:

    <div class=”bbcode_container”>
    <div class=”bbcode_quote”>
    <div class=”quote_container”>
    <div class=”bbcode_quote_container”> </div>
    AnnéePrécédenteTotal = CALCULATE(COUNT(Tbl_Demande[IdDemande]); SAMEPERIODLASTYEAR(Tbl_Demande[DateRecue]))</div>
    </div>
    </div>

    Celle-ci me calcule le total des demandes de l’année précédente pour les dates choisis mais pas par catégorie. (exemple comme un GROUPBY)
    J’ai cherché depuis plusieurs heures sans succès 🙁

    Eric a répondu Il y a 4 semaines 3 Membres · 3 Réponses
  • 3 Réponses
  • David

    Membre
    1 février 2024 à 15h33

    Bonjour Eric,

    Difficile de pouvoir t’aider sans avoir plus d’information sur ton modèle.

    As-tu la possibilité de partager un fichier PBIX avec des données d’exemple ?

  • Jean-luc

    Membre
    1 février 2024 à 15h36

    Bonjour Eric,

    Je suis d’accord avec David. La fonction utilisée semble la bonne mais sans le fichier .pbix, ce serait difficile de vous aider.

    Bon courage !

  • Eric

    Membre
    5 février 2024 à 15h38

    Merci!

    Une erreur de débutant.

    La formule était fonctionnelle…mais les filtres causaient problèmes.

Connectez-vous pour répondre.